在Debian/Ubuntu/CentOS等Linux系统上安装Flatpak

本文介绍在Linux系统上安装Flatpak应用程序的方法,支持Debian、Ubuntu、Arch Linux、Manjaro、openSUSE、CentOS、RHEL、Rocky Linux。

在Debian/Ubuntu上安装Flatpak

在Debian/Ubuntu 18.10及更高版本上,Flatpak的安装方式如下:

sudo apt update

sudo apt install flatpak

依赖关系树:

Building dependency tree... Done

Reading state information... Done

The following NEW packages will be installed:

flatpak

0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

Need to get 1,284 kB of archives.

After this operation, 6,722 kB of additional disk space will be used.

Get:1 http://security.debian.org/debian-security bullseye-security/main amd64 flatpak amd64 1.10.5-0+deb11u1 [1,284 kB]

Fetched 1,284 kB in 0s (21.7 MB/s)

Selecting previously unselected package flatpak.

(Reading database ... 143053 files and directories currently installed.)

Preparing to unpack .../flatpak_1.10.5-0+deb11u1_amd64.deb ...

Unpacking flatpak (1.10.5-0+deb11u1) ...

Setting up flatpak (1.10.5-0+deb11u1) ...

Processing triggers for dbus (1.12.20-2) ...

Processing triggers for man-db (2.9.4-2) ...

但对于较旧版本的Ubuntu,建议安装Flatpak的方法是添加存储库并从添加的存储库中安装:

sudo add-apt-repository ppa:flatpak/stable

sudo apt update

sudo apt install flatpak

为软件应用程序安装Flatpak插件,无需使用命令行即可安装应用程序:

sudo apt install gnome-software-plugin-flatpak

在Arch Linux/Manjaro上安装Flatpak

在Arch Linux上安装Flatpak是一个简单的过程。您只需要运行以下命令:

sudo pacman -Syy

sudo pacman -S flatpak

在openSUSE上安装Flatpak

Flatpak在当前由OpenSUSE Tumbleweed和Leap版本维护的默认OpenSUSE存储库中可用。

使用Zyper在OpenSUSE上安装Flatpak,如下所示:

sudo zypper install flatpak

在CentOS/RHEL/Rocky Linux上安装Flatpak

默认情况下,使用GNOME时,Flatpak在CentOS 7和更新版本上可用。如果没有,您可以在CentOS/RHEL/Rocky Linux上使用以下命令安装Flatpak:

sudo yum install flatpak

依赖关系树:

在Debian/Ubuntu/CentOS等Linux系统上安装Flatpak

注意,在以上截图的Is this ok [y/N]处输入y键后回车。

栏目相关文章